Back to overview
Maintenance

Scheduled maintenance

May 8, 2026 at 5:00pm UTC  –  May 8, 2026 at 11:34pm UTC
Affected services
D-Tech Group Website
Customers Area
Product License Manager
D-Tech API

Resolved
May 8, 2026 at 11:34pm UTC

Maintenance ended

Updated
May 8, 2026 at 11:34pm UTC

Maintenances in:

  • D-Tech SSO/CAS
  • D-Tech Customers Area
  • D-Tech URL Shortener
  • D-Tech Academy
  • D-Tech Website

finished.

Updated
May 8, 2026 at 9:55pm UTC

Maintenances in:

  • D-Tech Academy
  • D-Tech Website

finished.

Created
May 8, 2026 at 5:00pm UTC

At D-Tech Group, we work daily to keep our systems secure and efficient. For this reason, we are currently improving our infrastructure and services to provide you with the best possible experience when accessing and navigating our systems. You'll be able to enjoy all our services again very soon. We promise it won't be long!